BuddyPress Groupblog Plugin

. September 8, 2010 . 1 Comment

This BuddyPress Groupblog plugin by MariusOoms and reblevins extends the group functionality by enabling each group to have a single blog associated with it. Group members are automatically added to the blog and will have blog roles as set by the groupblog admin settings.

Features:
P2 integration and frontend posting.
Admin can set Template specific groupblogs.
Full blog theme integration. The included bp-groupblog theme mimics the group pages.
Automated blog registration at group creation stage.
Bypass default blog validation to allow dashes, underscores, numeral only and minimum character count.
Blog privacy settings are initially inherited from group privacy settings.
Group members are automatically added to the blog.
Blog roles match group roles as set by the group admin.
Solid error checking that the blog follows validation.
Group admin tab to access the group-blog settings.
Blog themes will have the ability to pull in group info and create a theme that could resemble the group exactly.
Leaving the group will downgrade the member role to ‘subscriber’.
Allow the group admin to select one of his/her existing blogs.
A new ajax backend.

More info and download: http://wordpress.org/extend/plugins/bp-groupblog/

Category: BuddyPress

Comments (1)

Trackback URL | Comments RSS Feed

  1. Anne says:

    Hello, I could really use some help with this groupblog plugin issue.

    I have a client with over 200 teacher users in a private network and have had them hanging for a while. When users join a group they are not added to the group blog, even when they visit then exit the blog.

    Originally was using wp2.9.2 – bp 1.2.4.1 – gb1.4.4 when we discovered the problem, noticed the plugin changelog for 1.4.6 said it was resolved
    So upgraded to wp3.0.1 & gb1.4.9, still didn’t work
    Upgraded bp to 1.2.5.2 still not working

    Tried rolling back to groupblog plugin 1.4.6 where changelog indicated it was fixed, no luck

    Currently am setup with wp3.0.1 – bp 1.2.5.2 – groupblog 1.4.9.

    I’ve tested this with all levels of users, various privacy settings and newly created groups vs existing groups. Have tried disabling then enabling plugins as well as turning off then back on the groupblog feature for a group. Have all other plugins disabled including mu-plugins, only things active are wp bp and groupblog. Sites are in subfolders, not using subdomains.

    Is there something I need to do to reset the thing after having used gb1.4.4 for a month, or can anyone verify if they’re having the same problem, or if it works for them??

Leave a Reply

Your email address will not be published. Required fields are marked *